mike (jibberwaukee) wrote in linux,
mike
jibberwaukee
linux

  • Mood:
  • Music:

Bewan ADSL PCI

Hey,

I've been having trouble with this modem, just can't seem to get it to work. I'm using gentoo, and I've updated to kernel 2.6.10 so that it comes with PPPoATM support.
I've looked on the Gentoo forums, but seemingly this is a very french modem, and no matter how much I try and follow them this thing seems to refuse to play.


Anyway, there are several portage ebuilds I have installed. linux-atm, bewan-adsl, and ppp.
I've got USE="atm" set in my make.conf.
I have configured my /etc/ppp/options like this:

lock
defaultroute
noipdefault
noauth
holdoff 4
maxfail 5
persist
asyncmap 0
lcp-echo-interval 2
lcp-echo-failure 7
user user.name@btbroadband.com
name user.name@btbroadband.com

plugin /usr/lib/pppd/2.4.2/pppoatm.so
0.38


but. I'm having trouble with the modem installation
it says: * To load the driver do 'modprobe unicorn_atm' and 'modprobe unicorn_pci'
however... I get: FATAL: Module unicorn_atm not found.

so. modprobe -l gives me four modules, unicorn_pci_eth.ko, unicorn_pci_atm.ko, unicorn_usb_eth.ko, unicorn_usb_atm.ko.
I have a pci modem so: modprobe unicorn_pci_eth
dmesg gives me:


ACPI: PCI interrupt 0000:00:07.0[A] -> GSI 11 (level, low) -> IRQ 11
unicorn_pci: AFE 70134
unicorn_pci: v 0.0.0, 20:02:10 Dec 25 2004
unicorn_pci: MSW parameters:
ActivationMode=1
ActTimeout=300000
AutoActivation=1
DebugLevel=0
DownstreamRate=8128
unicorn_pci: ExchangeDelay=20
FmPollingRate=1000
g_RefGain=28
g_Teqmode=7
InitTimeout=20000
Interoperability=0
unicorn_pci: LCD_Trig=15000
LOS_LOF_Trig=5000
LoopbackMode=0
MswDebugLevel=2
RetryTime=5000
TrainingDelay=120
unicorn_pci: useRFC019v=0
useRFC029v=7000
useRFC040v=0
useRFC041v=1
setINITIALDAC=93
unicorn_pci: useRFCFixedRate=1
useVCXO=0
_no_TS652=0
unicorn_pci: driver parameters: DebugLevel=0
unicorn_pci: v 0.0.0, 20:02:17 Dec 25 2004
unicorn_pci: PROTOCOL=,VPI=-2,VCI=-2,ENCAPS=
unicorn_pci: MAC=00:c7:8e:bd:4f:5b
divert: allocating divert_blk for dsl0
unicorn_msw: FmPollingRate=1000ms,InitTimeout=20000ms,ActTimeout=300000
unicorn_pci: AdslStatus=1
unicorn_msw: Current Modem State (3): ACTIVATING
unicorn_pci: MSW state: ACTIVATING


this is going to be huge, sorry about the length of this thing, but I can't really explain it otherwise.

anyway, the unicorn_pci_atm module won't load, because "device or resource busy"
I can load one or the other. when I do pppd, I get "Plugin /usr/lib/pppd/2.4.2/pppoatm.so loaded"
that's it. I think I got the pppoatm.so file from some other place so that is possibly the problem. Hm.
unicorntest gives me "current modem state: activating"

when I play with ifconfig dsl0 up, I get this in dmesg:

PCI: Unable to reserve mem region #1:10000@f7100000 for device 0000:00:07.0
start_device: Failed to initialize PCI memory,status=-16
unicorn_pci_init: inititalization of PCI failed
eql: remember to turn off Van-Jacobson compression on your slave devices.
unicorn_pci: AMU_EVENT_ACT_TIMEOUT
unicorn_msw: Timeout in activation!!!!
unicorn_pci: AdslStatus=1
unicorn_msw: Current Modem State (0): IDLE
unicorn_pci: MSW state: IDLE
unicorn_pci: AMU_EVENT_RETRY
unicorn_pci: AdslStatus=1
unicorn_msw: Current Modem State (3): ACTIVATING
unicorn_pci: MSW state: ACTIVATING
unicorn_pci: created proc entry at /proc/net/atm/UNICORN:0


edit: I've re-compiled my kernel again with some more option and I now have this in ifconfig:

eql Link encap:Serial Line IP
MASTER MTU:576 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:5
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

this looks suspiciously like my modem. however, I have no idea how to make it do something useful.

I am rather confused, any help would be fantastic.
thanks.
Subscribe
  • Post a new comment

    Error

    Anonymous comments are disabled in this journal

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

  • 8 comments